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Introduction 
 

Student Results Merger for Windows 95, 98, ME, NT, 2000, XP, etc. 
 
Student Results Merger is a program to help you handle / merge / process student results.  While the 
program was developed for the purpose of processing student results, it could also be used to process 
cycling race, horse race, swimming race, or keeping track of workers or volunteers, and/or various 
other results. 
 
This program is FREEWARE – that is, this program is free software.  Anyone - any person, any 
company, or any business - can download, distribute, and use this program for free.  No fees or 
payment is required. 
 
If you need to merge the results from a results spreadsheet into a master spreadsheet, then you could 
find Student Results Merger to be a very useful program. 
 
In a nut shell, here's a summary of the steps involved when working with Student Results Merger : 

1. You paste in a Master List of Student IDs.  This data does NOT need to be sorted. 

2. You paste in the Student Results List - consisting of the Student IDs and their Results (Tab, 
Comma, or Space separated data is supported).  e.g. from a spreadsheet.  This data does NOT 
need to be sorted. 

3. Click the "Process Results" button to generate a list of student results in the same order as the 
master list of student IDs, so that you can easily paste this back into the required column of 
your results spreadsheet. 



At the same time, the program will inform  you of any data errors / issues.  e.g. if a student 
has multiple results, if there are results for a student that is NOT in the master list, etc.  

 
If multiple result lines exist for a particular student, then you can select whether to treat this as an 
error, or get the program to select the highest result via the When Multiple Result Lines Exist for a 
Student options.  This is very useful to, for example, process quiz results where students can have 
multiple attempts at the quiz and it is their highest score that counts as their final result. 
 
N.B.  A Step by Step Guide with screen shots is provided below. 
 
Note well : 

• None of the lists need to be sorted - data is accepted in any order of student ID ! 

• The order of the results generated matches the order of the master list of student IDs so, you 
can simply paste the results data into your spreadsheet after the processing is completed. 

 
Developed using 32-bit Delphi. 

 

Why Write this Program ? 
 

This program was written to help the author merge student results for On-Line into Master Results 
Spreadsheet(s).  Prior to having this program, the results from these quizzes were difficult to merge, 
and the processing involved was time consuming and error prone, so I wrote the program to simplify 
the process and greatly reduce the chance of errors. 
 
The program can also be used for other activities, such as merging the approved / denied status for 
Deferred and Supplementary Exams into Master Results Spreadsheet(s), or merging exam results 
from individual markers into a Master Results Spreadsheet. 
 
So, the program can be very useful for teachers. 
 
Other people may find this program useful.  e.g. people who are maintaining the results for cycle 
races, or car races, etc. 

 

Installing and Using this Program 
 

To use this program, unzip the contents of the ZIP file to a directory - such as c:\Utils\ - and run the 
executable file : Student_Results_Merger.EXE. 
 
If you want the program to run automatically when Windows starts up, then select this option under 
the "File" menu in the program. 
 
If you would like to be able to run this program by clicking on an icon in the Windows Start Menu, 
or on the Windows Desktop, etc then you can use the "Create Shortcut ..." options under the 
program's File menu. 
 
I hope you find the program easy to use and useful. 

 



Uninstalling this Program 
 

At the present time, there is No Uninstall function. 
 
If you ever want to delete this program from your computer, then : 
 

• Exit the program, and delete it from wherever you installed it on your harddrive. 
 
Before doing this however : 
 

• If you have selected / enabled the "Auto-Run at Windows Start-up" option (under the File 
menu), then you should ensure that this option is not checked / enabled (which you can easily 
do by re-selecting the "Auto-Run at Windows Start-up" option under the File menu). 

 
• If you have used any of the "Create Shortcut ..." options under the File menu, then you 

should use the "Delete All Shortcuts" option under the File menu to remove these from your 
system. 

 
Simple as that ! 

 

Step by Step "Getting Started" Guide with Screen Shots 
 

In this section, the typical usage of this program will be demonstrated.  After this, we will discuss 
some of the more advanced options. 
 
N.B.  Student Results Merger is a program to help you handle / merge / process student results.  
While the program was developed for the purpose of processing student results, it could also be used 
to process cycling race, horse race, swimming race, or any other race results. 
 
First off, let's look at a simplified Master Results Spreadsheet – with just a few students to keep 
things as simple as possible.  In this mythical course, we have two on-line quizzes, 2 assignments, 
and an exam.  For such a course, our Master Results Spreadsheet might look something like this : 

 

 
 
Now, let's pretend that the first On-line Quiz has finished, and we have downloaded a CSV of 
the results.  Usually, not all students attempt the quiz, so there are gaps.  Our results might look 
like this : 

M129,9.7 
V001,9.9 



S023,10 
Q253,9.3 

But, when we load them into a spreadsheet and add column headings, these results would look a 
lot more presentable : 

 
 
If you compare the student ID's in the Quiz results with our Master Spreadsheet, you will notice 
that not all students attempted the quiz, and that the data is in different orders.  Let's use Student 
Results Processor to get the results into the order we need, and automatically allocate an Absent 
Fail (AF) for any students who did not attempt the Quiz.  When Student Results Processor is 
run, you will see this : 

 
 
The three areas at the top of the program's window above are : 

1. Master Student IDs List: The left hand area is for our Master List of Student IDs – we 
need to paste the data in from our master spreadsheet. 

2. Student ID + Results List: The middle area is for our results – i.e. a list of Student IDs 
and their results – again we need to paste the data in from the quiz results CSV file or 
spreadsheet. 

3. Results List: The right hand area will eventually contain the processed student results, 
and these will be in the same order as Master Student ID List. 

 



So, let's start with the left hand area, which needs to contain our Master List of Student IDs – we 
need to paste the data in from our master spreadsheet.  We need to select and then copy this data 
from our spreadsheet : 
 

 
 
Now we need to switch to the Student Results Processor (e.g. Alt-Tab) and then click the 
"Paste" button at the bottom of the "Master Student ID List" area : 
 

 



 
 
Next, we need to select and copy our quiz results – consisting of the Student ID and quiz result.  
So, we go back to our spreadsheet select and copy this data as follows : 
 

 
 
Now we need to switch to the Student Results Processor (e.g. Alt-Tab) and then click the 
"Paste" button at the bottom of the "Student ID + Result List" area.  Also note that because the 
data comes from a spreadsheet, the data is TAB separated, so we have selected TAB as the 
delimiter. 
 

 



 
 
Now we click the "Process Results" button. 
 

 
 
And this generates the results for all students and displays a report showing any Errors or the 
Errors and Warnings depending on what reporting option you have selected.  Now, we click the 
"Copy" button at the bottom of the "Results (same Order as Master List)" area: 
 
 
Finally, we can paste the data into the Quiz 1 column of our Master Results Spreadsheet : 
 

 
 

So, as you can see : 

• The order of the data does NOT matter – the results are ALWAYS generated in the same 
order as the Master Student ID List. 

• In the above example, an Absent Fail (AF) is automatically awarded for any student who did 
not attempt the assessment, however you can choose to allocate any result you like - via the 



"If no result is found for Student, allocate them" group box's radio buttons.  e.g. 0, nothing / 
blank, etc. 

 
 

Step by Step Guide for Handling Results from Multiple Markers 
 

In this section, we run through how the program can help you deal with the results from multiple 
markers at once.  This feature is support for v1.07 of the program or later. 
 
Please note:  You should make sure that you run through and understand the material covered in the 
"Step by Step "Getting Started" Guide with Screen Shots" (above) before proceeding with this 
section.  This section assumes that you know the above material and will skip over much that was 
covered in the above section. 
 
OK, once again let's start with the Master Results Spreadsheet.  Here I have included the results from 
the individual markers in different tabs (sheets) of the spreadsheet – see the tabs along the bottom for 
Marker 1, Marker 2, etc – but the results from different markers could just as easily be in different 
spreadsheets. 

 

 
 
OK, so let us select all Student ID's and copy them to Windows Clipboard (select all IDs with 
the mouse and then type Ctrl-C on the keyboard, or use the Edit -> Copy menu option). 

 



Then switch to Student Results Processor and paste the ID's in.  (Click the "Paste" button 
below the "Master Student ID List" in the middle). 
Now, return to Excel and click on the "Ass 1 – Marker 1" tab at the bottom.  Select all Student 
ID's plus results copy them to Windows Clipboard (select with the mouse and then type Ctrl-C 
on the keyboard, or use the Edit -> Copy menu option). 

 
Now, switch to Student Results Processor and paste the ID+Results in.  (Click the "Paste" 
button below the " Student ID + Result List"). 
Now, return to Excel and repeat this process for the other assignment markers, in this case "Ass 
1 – Marker 2" and "Ass 1 – Marker 3" – see the tabs at the bottom. 
After pasting the ID+Results for all markers into Student Results Processor, we now have 
something like this: 

 
Now all we need to do is click the "Process Results" button and the program will remove items 
with blank results from the Student ID+Results List, and then automatically process the results, 
check for duplicates, check for assessment marked by more than 1 marker, etc, and then generate 
the results in the "Results" column (on the right).   
 
If multiple result lines exist for a particular student, then you can select whether to treat this as 



an error, or get the program to select the highest result via the When Multiple Result Lines Exist 
for a Student options.  This is very useful to, for example, process quiz results where students 
can have multiple attempts at the quiz and it is their highest score that counts as their final result. 
 
Now, all we need to do is click the "Copy" button blow in the "Results" column (on the right), 
return to Excel, go to the appropriate sheet / tab and column in our Master Spreadsheet, and 
paste the results in, as follows: 

 
Please Note:  One of the results is shown as "*ERROR*" because 2 markers had marked the 
same assignment for the same student. 

 

Advanced Options 
• If no result is found for a Student, allocate them : 

o AF (Absent Fail) 
o Blank.  i.e. no result 
o 0  i.e. zero. 
o Other 

 
Explanation: If no result is found for a student in the list of results (e.g. because the didn't submit an 
assignment or sit an exam), then this option specifies what result will be allocated for the student.   

 
• Process / Allow How Many Results per Line : 

o One and ignore any additional results per line 
o Multiple / Many results per line 

Explanation: If "only 1 result per line" is specified then any other results on the line will be ignored 
(and reported as warnings on the report – if warnings are specified to be shown).  If "multiple results 
per line" is specified then each line could have any number of results.   Example, if you are 
processing exam results like this : 
 
 Q100,10,3,4, 15, 3 
 Q200,8,4,3,12,1 
 etc 
 
then you would select the "multiple results per line". 

 
• When Multiple Result Lines Exist for a Student: 

If multiple result lines exist for a particular student, then you can select whether to treat this as an 
error, or get the program to select the highest result via the When Multiple Result Lines Exist for a 



Student options.  This is very useful to, for example, process quiz results where students can have 
multiple attempts at the quiz and it is their highest score that counts as their final result. 

 
 

• Field Delimiter : 
o TAB 
o Comma 
o Space 
o Other 

 
Explanation: This is pretty self explanatory.  This setting allows you to specify what delimiter is 
used to separate the fields of your data.  If you are copying the data from a spreadsheet, then you 
would have TAB separated data. 

 
• Treat Multiple Consecutive Delimiters as One : 

 
Explanation: If you data like this : 
 
 Q100,5 
 Q200,,,,,,3 
 Q300,,2 
 
then it will all be treated like this : 
 
 Q100,5 
 Q200,3 
 Q300,2 
 
if you check this option. 

 
• Truncate Student IDs to NN characters : 

 
Explanation: This checkbox / setting enables you to specify the trimming of student-ids to allow the 
correct comparison of master and result student-IDs - which may be of different lengths due to 
addition of check digits or other items to one or both student IDs.  For example, in he Master 
student-id list, a student ID may be "Q123", but in the results list, the student-id may be "Q123x".  
To be able to compare these IDs correctly, this "Truncate Student IDs to NN characters" option 
should be used to truncate all student-IDs to 4 characters. 

 
• Remove these chars from all fields : 

 
Explanation: If this setting's checkbox is checked, then any characters typed in the data entry box 
next to it will be automatically removed from all student ID and result data before it is processed 
further.   

 

Limitations / Restrictions of Use 
 

None.  This program is FREEWARE – that is, this program is free software.  Anyone - any person, 
any company, or any business - can use this program for free.  Please download, distribute, and use it 
freely.  No fees or payment is required. 
 



If you would like to support my efforts, and would like to send me a donation, then please feel free 
to do so by clicking on the "PayPal Donate" icon on the Help  About screen.  

 

Warranty 
 

This software and the accompanying files are provided "as is" and without warranties as to 
performance or merchantability or any other warranties whether expressed or implied.  If you do find 
any faults with this program, email me and let me know, and I will do my best to fix it ASAP. 

 

The Future 
 

In the future, many improvements could be made to this program, 
such as : 

• A Linux version ?  e.g. via Kylix (which is Delphi for Linux).  This should be pretty easy to 
do.  In the meantime, Linux users could run the Windows version of this program under 
emulation.  e.g. Wine. 

• A MAC OS version ?  Again, even if I had to port my code to something similar to C++ 
Builder, then this should  be pretty easy to do.  In the meantime, MAC users could run the 
Windows version of this program under emulation.  e.g. Virtual PC. 

• Directly linking to spreadsheets - although I am very worried about doing anything like this, 
as people would need to select : 

o which column in which spreadsheet is their master list of Student IDs, 

o which  column in which spreadsheet is the results that they are merging in, and, 

o which column in which spreadsheet is where they want to the merged results to go. 

It would be very easy to make a mistake in any of these steps, and it could therefore be fairly 
easily for people to overwrite results or corrupt spreadsheets.  As such, I am very reluctant to 
explore this functionality further at this stage. 

The current solution is much simpler and far less risky or error prone. 

• Anything else ?  Let me know ! 
 
If you would like any of these improvements, or would like to suggest more, please email me and let 
me know. 

 

Amendment History 
 

Ver Date Details 
0.1 14-July-2004 • Private BETA / Test Release #1. 
0.2 15-July-2004 • Private BETA / Test Release #2. 
1.0 12-Oct-2004 • First Semi-Public Release to Infocom Staff at CQU. 

1.01 1-Nov-2004 

• Make the program more flexible / useful by allowing the user to 
specify what to allocate to students who do NOT have any results.  
This allows the program to merge the approved / denied status of 
Deferred Exams, as well as other forms of result. 

1.02 2-Nov-2004 • Various minor enhancements.  Abort button aborts immediately, and 



the results report state the fact that an abort was requested.  
Additional information is displayed during processing. 

1.03 17-Mar-2005 

• First Public Release. 
• Add in the "Process / Allow How Many Results per Line" options.  

If you want to process / allow each student to have just one result, 
then use the "One and ignore any additional results per line" option, 
otherwise, if you want to allow students to have multiple results per 
line, then use the "Multiple / Many results per line".  See the 
Advanced Options section above for further details. 

• Instead of automatically analysing the data and selecting the 
delimiter(s) to use, allow the user to specify which delimiter to use 
and whether to treat multiple consecutive occurrences of the 
delimiter as one occurrence.  This ensures that the data is being 
processed according to the user's particular needs.  See the 
Advanced Options section above for further details. 

• After pasting data, move the view point back to the top of the list, 
rather than leaving it at the end of the list. 

1.04 07-Mar-2006 

• Add in a "Trim White Space from Fields" checkbox which invokes 
some extra trimming while processing fields when checked.  (Dave 
O of CQU had an issue with an extra space at the start of some data).  
See the Advanced Options section above for further details. 

• Improve information displayed in selected warning messages. 

1.05 29-May-2006 

• Add in "Truncate Student IDs to NN characters" checkbox / setting 
to enable the user to specify the trimming of student-ids to allow the 
correct comparison of master and result student IDs - which may be 
of different lengths due to addition of check digits or other items to 
one or both student IDs.  Special thanks to Peter C of CQU for 
suggesting this improvement.  See the Advanced Options section 
above for further details. 

• Change the default setting for "On the Error Report, show" to "Error 
Messages Only".  See the Advanced Options section above for 
further details. 

1.06 21-Jun-2006 

• Add a "Help" button to the main window – this does the same as the 
Help -> Help + Step by Step Guide menu option. 

• Add a new "Remove these chars from all fields" setting onto the 
main screen.  If this setting's checkbox is checked, then any 
characters typed in the data entry box next to it will be automatically 
removed from all student ID and result data before it is processed 
further.  Special thanks to Peter C of CQU for suggesting this 
improvement.  See the Advanced Options section above for further 
details. 

1.07 13-Sep-2007 

• Add in support for processing multiple result lines exist for a 
particular student.  If multiple result lines exist for a particular 
student, then you can select whether to treat this as an error, or get 
the program to select the highest result via the When Multiple Result 
Lines Exist for a Student options.  This is very useful to, for 
example, process quiz results where students can have multiple 
attempts at the quiz and it is their highest score that counts as their 
final result. 

• Add support for handling the results for multiple markers at once.  
This involved a simple change to the way the program deals with 
data.  The program now removes all lines from the ID+Result list 



where the result is blank before doing any processing.  This means 
that you can now paste in the results from multiple markers at once 
and the program will handle them correctly.  This should save people 
a lot of pre-sorting or post-merging (via multiple columns in a 
spreadsheet) when multiple markers are involved.  If multiple 
markers mark the same assignment, then it will either be flagged as 
an error, or the highest result will be selected, depending on the 
settings you have chosen for When Multiple Result Lines Exist for a 
Student options. 

• Remove the "On the Error Report, show either All Information, 
Warning and Error Messages or Error Messages Only" option – the 
report shown after processing contains multiple tabs – one for 
Information Messages / Processing summary, one for Warning 
messages, and one for Error messages. 

1.08 18-Oct-2007 

• Warning: Do NOT use v1.07 – please upgrade to v1.08. 
• Fixed a bug that was inadvertently introduced in the prior version 

(v1.07) which caused some students to be given the wrong result. 
• Anyone who processed any results with the prior version (v1.07) 

should reprocess them using this latest version (v1.08). 
• I apologise for any inconvenience caused.  Just glad I noticed this 

before the start of end of term results processing … 
 
This program is FREEWARE – that is, this program is free software.  Anyone - any person, any company, 
or any business - can use this program for free.  Please download, distribute, and use it freely.  No fees or 
payment is required. 
 
If this program was not downloaded from my Home Page, then it is possibly an old version.  The latest 
version of this program is available from my WEB page - see below. 
 
 Mike "Moose" O'Malley 
____________________________________________________ 
 Moose's Software Valley - Established July, 1996. 
 WEB:  http://move.to/moose 
____________________________________________________ 
 


